Impeller Module

PR1568
Product No. PR1568

$6.64

Find a Store Out of Stock
Impeller Module for the HOT Magnum® PC250. 3 parts.
Impeller Module is rated 5.0 out of 5 by 3.
Rated 5 out of 5 by from This part for my filter, has it running like new PS this filter is at least 15 yrs old This filter is over 15 years old and I have only replaced the impeller Module This is a great product, I have two of these filters they last many years Thanks !!!
Date published: 2015-07-19
Rated 5 out of 5 by from very good used Marieland product for over 6 years fast shipping - great service - would recommend to friends
Date published: 2013-09-25
Rated 5 out of 5 by from 3-part impeller for Hang On Tank Filter/pump Older defective impeller was replaced by new one which did the trick
Date published: 2013-08-30
  • y_2018, m_4, d_21, h_2
  • bvseo_bulk, prod_bvrr, vn_bulk_2.0.8
  • cp_1, bvpage1
  • co_hasreviews, tv_0, tr_3
  • loc_en_US, sid_PR1568, prod, sort_[SortEntry(order=SUBMISSION_TIME, direction=DESCENDING)]
  • clientName_marineland

Where would I find the piece that goes on the impeller then inside the impeller modular?

Asked by: Rosco723
Sounds like you need to buy a new impeller. http://www.marineland.com/Products/aquarium-parts/Filtration-Products-and-Skimmers/HOT-Magnum-Parts/Magnetic-Impeller-Assembly-Blue-for-HOT-Magnum-PC250.aspx BREX
Answered by: BREX
Date published: 2018-01-05

Will impeller module for 250 fit magnum 400 filter? Bought filters about 17 years ago.

Asked by: Mad dog
We do not make a Magnum 400, and never have, but we did make a Magnum 350. The impeller module for the HOT Magnum 250 will not fit the Magnum 350, however. BREX
Answered by: BREX
Date published: 2017-01-25

is the impeler included with this?

Asked by: TimVener
No, that would be sold separately. BREX
Answered by: BREX
Date published: 2014-09-29

Does this include the impeller?

It's very difficult to get the assembly to sit properly or something, like the impeller isn't grabbing correctly. Once in a while I will be able to get it to go I believe full speed. Sometimes it doesn't work at all, right after cleaning the filter.
Asked by: Chief0x
I have had a similar problem. When you assemble the filter after cleaning make sure you seat the 8 inch tube that is in the center of the assembly all the way down into the impeller assembly at the bottom of the pump. That may help, but also likely is that your 3-part impeller is worn and the 3 little triangular plastic tips are broken and don't seat or lock into one of the oyster shell halves before you snap them together. This allows it to spin inside the impeller assembly and it won't pump properly.. Simply order a new assembly for under 7 bucks.
Answered by: skywarrior
Date published: 2014-01-04
  • y_2018, m_4, d_21, h_2CST
  • bvseo_bulk, prod_bvqa, vn_bulk_2.0.8
  • cp_1, bvpage1
  • co_hasquestionsanswers, tq_4
  • loc_en_US, sid_PR1568, prod, sort_[SortEntry(order=LAST_APPROVED_ANSWER_SUBMISSION_TIME, direction=DESCENDING)]
  • clientName_marineland